Quill.org Downtime
Incident Report for Quill.org
Resolved
The incident has been resolved. Thank you for your patience. If you are still experiencing any issues, please reach out to support@quill.org.
Posted Feb 24, 2022 - 17:18 UTC
Investigating
We're currently experiencing a brief outage. Our team is actively looking into the matter, and we should have a fix in place shortly. This status will update as soon as we do. Thanks for your patience, and our sincerest apologies for any inconvenience.
Posted Feb 24, 2022 - 16:48 UTC
This incident affected: Quill.org.