Quill.org Downtime
Incident Report for Quill.org
Resolved
This incident has been resolved.
Posted Jun 02, 2023 - 17:08 UTC
Investigating
We're currently experiencing a brief outage. Our team is actively looking into the matter, and we should have a fix in place shortly. This status will update as soon as we do. Thanks for your patience, and our sincerest apologies for any inconvenience.
Posted Jun 02, 2023 - 16:47 UTC
This incident affected: Quill.org and Tools (Quill Connect, Quill Diagnostic, Quill Lessons, Quill Grammar, Quill Proofreader).