Quill Reports Error
Incident Report for Quill.org
Resolved
This incident has been resolved. Thank you for your patience!
Posted Jan 21, 2022 - 15:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 21, 2022 - 14:51 UTC
Investigating
We're currently investigating an issue where some reports are not allowing teachers to switch between classes. Our engineering team is putting a fix into place, and we will update this page immediately once the error has been resolved. In the meantime, please reach out to support@quill.org with any further questions.
Posted Jan 21, 2022 - 14:23 UTC
This incident affected: Quill.org.