Quill Lessons Error
Incident Report for Quill.org
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 16:25 UTC
Investigating
We're currently investigating an issue with our Quill Lessons activities. Our engineering team is putting a fix into place, and we will update this page immediately once the error has been resolved. In the meantime, please reach out to support@quill.org with any further questions.
Posted Oct 04, 2021 - 14:35 UTC
This incident affected: Tools (Quill Lessons).